如何解决Putty报错: Can’t agree a key change algorithm

Putty是常用的SSH连接软件。它非常轻量,而且界面清爽,因此即便市面上有各种各样高级的SSH软件,我依旧倾向于使用Putty连接服务器。

有的时候,我们在使用Putty连接服务器的时候会出现下面这样的报错:

Putty Fatal Error: Can’t agree a key change algorithm (available: xxx……

比如下面这张图:

从字面上看,这个报错的提示是Putty无法和服务器进行密钥算法交互。

那么,为何会出现这种情况呢?

实际上,随着Linux版本的更新,服务器支持的加密算法也在不断更新,而老版本的Putty不支持SSH服务器新的加密算法,就会出现这样的问题。

因此,我们只需要更新计算机上的Putty程序,就可以解决这个问题啦!您可以在这里下载最新版本的Putty程序:https://www.putty.org/

 

怎么样,是不是很简单呢?如果您有任何疑问,欢迎在这里留言与大家讨论哈。本文作者为香菇肥牛,原文链接为https://qing.su/article/167.html, 转载需注明原文链接。谢谢!

2 thoughts on “如何解决Putty报错: Can’t agree a key change algorithm”

Leave a Comment